*offizielles deutsches flaskmpeg & dvdtoogm board*
Registrierung Kalender Mitgliederliste Teammitglieder Suche Häufig gestellte Fragen FlaskChat Zur Startseite

*offizielles deutsches flaskmpeg & dvdtoogm board* » *dvd=>avi/ogm/mkv/mp4* » DVD->Xvid/x264 mit Megui: Programm mit anamorphen Encoding » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen DVD->Xvid/x264 mit Megui: Programm mit anamorphen Encoding
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

DVD->Xvid/x264 mit Megui: Programm mit anamorphen Encoding Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hallo,

ich möchte eine DVD mit 16:9 (PAL) in Xvid bzw. x264 wandeln. Dabei habe ich derzeit das Problem, dass Megui Eierköpfe ausgibt. Soweit ich mich eingelesen habe, liegt das am anamorphen Video. Ich weiß aber nicht genau, wie ich vorgehen muss.

DVD mit quadratischen Pixeln in mpeg-4 umrechnen und dann vom Decoder richtig ausrichten lassen? Dann muss sicher dieser Flag gesetzt werden, in welches Verhältnis der Decoder ausrichten soll. Wo kann ich das den setzen?

Edit
Über den Script Creator habe ich eine Möglichkeit gefunden, das anzupassen. Da wird aus 720x576 704x400 gemacht. Dabei geht doch aber Auflösung verloren. Ich suchte eine Möglichkeit das ganze ohne Verluste an Bildinformationen zu machen, also mit 720x576 (Balken gibt es keine).

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von t.taylor: 20.10.2008 16:34.

20.10.2008 16:28 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
Selur
spamming old Newbie


images/avatars/avatar-173.png

Dabei seit: 13.03.2002
Beiträge: 10.856

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Wenn Du anamorph encoden willst in MeGui solltest Du:
1. Resize deaktivieren
2. das 'clever (tm) anamorphic encoding' activieren
Falls Du es noch nicht kennst hilft vielleicht auch ein Blick ins etwas betagte 'MeGui Essentials'

Cu Selur

__________________
Hybrid
20.10.2008 19:25 Beiträge von Selur suchen Nehmen Sie Selur in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Das isnd doch alles nur Optionen im Skript Creator. Ich will ja aber kein Skript schreiben sondern das Flag in den MPEG4-Stream setzen. Ein Skript habe ich schon.

Außerdem kann ich dort keine d2v laden, hier kommt: "there is no function named DGDecode_mpeg2source". In meinem Skript klappt d2v mit DGDecode problemlos.

Resize geht im Sript Creatr nicht zu ändern, ist grau.
23.10.2008 18:33 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
Selur
spamming old Newbie


images/avatars/avatar-173.png

Dabei seit: 13.03.2002
Beiträge: 10.856

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

1. wenn man MeGui nicht sagt, dass es anamorph encoden soll resized es intern auf Square Pixel (und dieses stellt man im Skript editor ein, da MeGui dann in das Skript einen Kommentar schriebt, den es biem Multiplexen später ausliest)
2. wenn Du den Flag im Nachhinein ändern willst geht das mit Yamb bzw. MP4Box
3. das sollte nur passieren, wenn entweder Avisynth nicht installiert ist, oder MeGui nicht upgedated wurde

Cu Selur

__________________
Hybrid
24.10.2008 02:47 Beiträge von Selur suchen Nehmen Sie Selur in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

zu 1.) OK, das wede ich mal versuchen.
zu 2.) Das st doch aber nur das Flag im Container? Wie geht das denn mit Yamb? Dort habe ich keine solche Option gefunden. Hab alleridngs noch die v1.6
zu 3.) Updates bei MeGui mache ich nur ungern, weil es mir bei fast jedem Update etwas durcheinder wirft, das vorher klappte.
24.10.2008 16:23 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
Selur
spamming old Newbie


images/avatars/avatar-173.png

Dabei seit: 13.03.2002
Beiträge: 10.856

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

zu 2.:
Gerade gecheckt, geht nicht mit YAMB 1.6 braucht man eine neuere Version.
Manuell mit mp4box geht es über:
code:
1:
MP4Box.exe -par 1=X:Y YourVideo.mp4

wobei der PAR dann X:Y ist.
Wenn es H264 Material ist sollt es auch mit H264info gehen.
(Achtung mit h264info muss man den raw stream bearbeiten, nicht den stream innerhalb eines containers!)

Bei Mpeg-4ASP Material in einem .avi container kann man mit 'MPEG4 Modifier' das PAR/DAR ändern.

zu 3.: Wobei ein Update doch recht sinnig erscheint wenn etwas nicht geht. Augenzwinkern

Cu Selur

__________________
Hybrid
24.10.2008 16:46 Beiträge von Selur suchen Nehmen Sie Selur in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Zitat:
Original von Selur
zu 3.: Wobei ein Update doch recht sinnig erscheint wenn etwas nicht geht. Augenzwinkern


Sagen wir mal so. Grds. geht MeGui ja, aber durch Updates hatte ich bisher immer das Problem, dass bestimmte Sachen überhaupt nicht mehr gingen - schwerwiegendere als ein inaktiver Haken, daher mache ich erst dann wieder ein Update, wenn überhaupt nichts mehr läuft.

Da das ganze im Script Creator abläuft sollte es doch gehen, wenn ich auf meinem Notebook MeGui update und dort ein Script erstelle, dieses dann auf meinen Rechner kopiere (ggf. Pfadänderungen) und so encoden lasse?

Evtl. geht es ja auch, wenn ich das Skript am Rechner erstelle lasse (mit Resize) und dass dann manuell ändere (also wieder 720x576). Der rest sollte dann ja im Skript stimmen.
24.10.2008 23:18 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Ich kanns gerade nicht testen, weil ich keine d2v in den Skriptcreator laden kann. Muss ich da irgendwas anders machen? Ich bekomme die Fehlermeldung "there is no function named "DGDecode_Mpeg2Source"".

DGDecode.dll liegt im Plugin-Verzeichnis. Ist die gleiche Version, mit der die d2v erstellt wurde.
26.10.2008 09:43 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
Selur
spamming old Newbie


images/avatars/avatar-173.png

Dabei seit: 13.03.2002
Beiträge: 10.856

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Avisynth ist aber installiert, oder ?

__________________
Hybrid
26.10.2008 09:52 Beiträge von Selur suchen Nehmen Sie Selur in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Ja, ist drauf.

---

Ich habe das jetzt einmal mal anders versucht. Als Input eine mp4 genommen und später manuell mpeg2source eingesetzt, außerdem den Resizefilter komplett rausgenommen, so dass das ganze in 720x576 encodet wird. Den Haken bei clever (tm) anamorphic encoding gemacht. Im mpc wird das ganze trotzdem verzerrt dargestellt. Kann man aus der fertigen Datei auslesen, ob das Flag in den Stream gesetzt wurde?
26.10.2008 10:01 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
Selur
spamming old Newbie


images/avatars/avatar-173.png

Dabei seit: 13.03.2002
Beiträge: 10.856

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Zitat:
Kann man aus der fertigen Datei auslesen, ob das Flag in den Stream gesetzt wurde?

avinaptic, mediainfo und vermutlich auch gspot sollten da helfen.
Vielleicht auch ganz interessant: http://brother-john.net/ar-vergleich.html

Cu Selur

__________________
Hybrid
26.10.2008 11:20 Beiträge von Selur suchen Nehmen Sie Selur in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Wenn bei Mediainfo hinter der Auflösung 16:9 steht sollte das Flag richtig gesetzt sein?

Hast du eine Ahnung wieso der meine d2v nicht will?
27.10.2008 18:53 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

So, hab jetzt nochmal einen Test auf dem Laptop gemacht. Da dort das OS noch frishc war, musste ich ffdshow-tryouts neu installieren, habe das von clsid genommen. Meine kurz encodete Test-AVI wurde korrekt entzerrt dargestellt. Auf dem PC wurde es falsch dargestellt.

Auf dem Laptop habe ich keinerlei Ändeurngen in den Einstellungen vorgenommen. Auf dem Laptop wurde die Option Use Overlay Mixer aktiviert.
28.10.2008 18:30 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
Selur
spamming old Newbie


images/avatars/avatar-173.png

Dabei seit: 13.03.2002
Beiträge: 10.856

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Zitat:
Wenn bei Mediainfo hinter der Auflösung 16:9 steht sollte das Flag richtig gesetzt sein?

k.A. ich nutzte MediaInfo nur per Command line, da sind dann die Werte bei Display Aspekt Ratio und Pixl Aspekt Ratio interessant. (eventuell mediaInfo mit --Full aufrufen)

Zitat:
Hast du eine Ahnung wieso der meine d2v nicht will?

Wenn Du Dir sicher bist, dass die Datei wirklich mit der DGIndex Version erstellt wurde zu der auch die DGDecode.dll gehört: Nein
Würde eventuell mal unter Options->Settings->Program Paths die Pfade unter 'Others' alle checken.

Zitat:
Meine kurz encodete Test-AVI wurde korrekt entzerrt dargestellt. Auf dem PC wurde es falsch dargestellt.

-> dann hast Du vermutlich etwas eingestellt oder installiert was dazu führt, dass auf dem PC eine andere Filterkette aufgebaut wird.

Cu Selur

__________________
Hybrid
28.10.2008 18:47 Beiträge von Selur suchen Nehmen Sie Selur in Ihre Freundesliste auf
t.taylor
Jungspund


Dabei seit: 20.10.2008
Beiträge: 14

Themenstarter Thema begonnen von t.taylor
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Ich werd das mal testen, woran es liegt.

Welche der Versionen von ffdshow würdest du denn empfehlen. Bei der die ich jetzt installiert habe, werden z. B. unter Start keine Konfigurationsmenüs erstellt. Aufdem PC habe ich eine von Celtric Druid die sich unter Sourceforge gar nicht findet.

Da es ja für den PAR nur 4 Werte geben kann, kann ich den ja auch selber setzen. MeGui hat mir in das Skript folgendes geschrieben:

code:
1:
2:
global MeGUI_darx = 16
global MeGUI_dary = 11


Die Werte 16 udn 11 hab ich selber eingetragen. Bei einer 16:9-PAL-DVD sind das nach dem Encodingswissen die korrekten Werte für den PAR. Wenn ich die manuell setze erspare ich mir das ganze gebastel über MeGui.
29.10.2008 21:15 E-Mail an t.taylor senden Beiträge von t.taylor suchen Nehmen Sie t.taylor in Ihre Freundesliste auf
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
*offizielles deutsches flaskmpeg & dvdtoogm board* » *dvd=>avi/ogm/mkv/mp4* » DVD->Xvid/x264 mit Megui: Programm mit anamorphen Encoding

WBB, entwickelt von WoltLab GmBH